5 replies [Last post]
acerynes
acerynes's picture
 Offline
VBMWMO #9334
Seattle
Joined: 10/07/2015
Posts: 23

Hello all,
I could use some info help. My 1964 r69s has developed a new problem of sorts... i ride home from work around midnight and the past month I have noticed when I start my climb up to freeway speeds, my speedo backlight becomes dimmer and dimmer until its completely out. When I have the bike in N its on.. when Im going around 30 and below..its on. My understanding is that the speedo grounds itself through the speedo cable, and through the speedo shell itself. Ive checked the wiring in the headlight bucket and it appears to be correct. Has anyone ran into this issue before?
thanks..

schrader7032
schrader7032's picture
 Offline
VBMWMO #7032
San Antonio, TX
Joined: 10/27/2006
Posts: 6808
Sounds strange. I'm aware

Sounds strange. I'm aware that the battery is there to supply power to lights, etc., when the RPMs drop down...when the RPMs are up, the bike's generator should be supplying power needs. How old is the battery? What kind of voltage do you see at the battery terminals when the RPMs are up...in other words, are you getting good charging voltage out of the generator.

__________________

Kurt in S.A.
'78 R100/7 '69 R69S '52 R25/2

wa1nca
wa1nca's picture
 Offline
VBMWMO #8374
Ashfield Ma.
Joined: 09/27/2012
Posts: 525
Erractic speedo light

I have to assume your headlight is working ok as you didnt mention a problem with the headlight also not working correctly at different speeds

Loose bulb in socket you can bend the center tab up to get a tighter fit
Yes the speedo bulb does get its ground through the speedo cable
You can bypass the cable by running a small wire from the speedo shell to ground #31 or large Brown wire on switch board to eliminate a flaky ground

Tommy

__________________

Tommy Byrnes
54 R51/3 55 R50 64 R27 68 R69US 68 Sears Allstate 250 (Puch)

acerynes
acerynes's picture
 Offline
VBMWMO #9334
Seattle
Joined: 10/07/2015
Posts: 23
thanks for the quick responses..

I should have added that, the headlight and the hi-lo function work per the book. They dont flicker at all... The ignition system I have in, is the solid state system from czech republic (https://w6rec.com/duane/bmw/mz/mz.htm) <-- mentions it there. I have the system where both units are replaced. I have had zero issues with the system since the install and pretty impressed with it. That being said, just for kicks when you mentioned the battery statement. I put my tender out on it to see if that helps anything.

acerynes
acerynes's picture
 Offline
VBMWMO #9334
Seattle
Joined: 10/07/2015
Posts: 23
stupid question time

How do people do the bypass method. Ring terminal from the speedo to the grounding wire the most common method?
could my speedo cable also be the issue?

wa1nca
wa1nca's picture
 Offline
VBMWMO #8374
Ashfield Ma.
Joined: 09/27/2012
Posts: 525
Intermittent speedo light

Eliminate a weak ground 1st
You can bypass the cable by running a small wire from the speedo shell to ground #31 or large Brown wire on switch board to eliminate a flaky ground

Only thing left is a flaky speedo bulb or power to it

To eliminate flaky power to speedo bulb just run a bypass wire from the bulb socket to the tailight connection or headlight terminal on the switch board

Next bad socket or bulb

Tommy

__________________

Tommy Byrnes
54 R51/3 55 R50 64 R27 68 R69US 68 Sears Allstate 250 (Puch)

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.